Superset - Dremio: Time Grain shows 0 options(s)

Hi!

@balaji.ramaswamy I would appreciate some help with connecting Dremio to Superset.

I followed the steps described in the documentation and successfully established a connection between Superset and Dremio. Reflections, Acceleration, everything works great except the “Time Grain” selection on any of the charts or tables.

It shows “0 option(s)” for every datetime/timestamp column I have… I checked the dataset and the aggregate reflection both are timestamps. I have both “original” and “day” aggregation on different columns and none of them show any option for Time Grain.

My connection is using pyodb: “dremio+pyodbc://root:XXXXXXXXXX@…/dremio”

If I use my Druid datasource, then the Time Grain options are available…

Is it some configuration I am missing on the Dremio end or maybe some extra Superset actions needed that I am missing?

It is not a problem for aggregate tables or pie/bar charts, but if I have a linechart, it is not ideal to have a datapoint for every millisecond… :slight_smile:

Thanks in advance!

@balaji.ramaswamy

Any chance to look into this? :slight_smile: