TCP/IP problem between SQL Server on Windows and Dremio on Linux Virtual Machine

Hello everyone,

I’m trying to add an external source to Dremio but it won’t work and i got this error message.

I verified multiple times that the connection information where right so i think it’s another problem.

I have installed Dremio on a Virtual Machine (Ubuntu) and my Microsoft SQL Server is on Windows. The two devices are linked because they can ping eachother.

My Windows 1433 Port is open and the TCP/IP connection is enabled. I also tried to link them using another software (DBeaver). The DBeaver on Windows worked perfectly but the one on Linux won’t connect to my SQL Server and gave me an error:
“Error: connect timed out. Verify the connection properties. Make sure that an instance of SQL Server is running on the host and accepting TCP/IP connections at the port. Make sure that TCP connections to the port are not blocked by a firewall.”

So here I am seeking help. If you have a potential answer i would be pleased to here it.
Thank you in advence.


@LucasAvril How did you validate the port is open? Any chance you can try “telnet 1433” and comes back without a connection refused or a timed out?

@balaji.ramaswamy I created a rule that should allow all the trafic on the port 1433.
But you are actually right the port isn’t open when I verify with Telnet:

He is telling me that he is trying to connect on port 23 though. Do you have an idea on how to fix it ?

@LucasAvril You have mentioned “He is telling me that he is trying to connect on port 23 though”, who is this? your SQL Server SA?

@balaji.ramaswamy This is the response of “telnet 1433” on my cmd. If I translate it in english it says: “Unable to open a connection to the host, on port 23: Connection failure”

@LucasAvril I assume you did “telnet <host_name> 1433”?

@balaji.ramaswamy When i do “telnet <my_host_name> 1433” my cmd become empty so I wait.
And then it do not give anything in response.

@LucasAvril That means the port is open, What is the error message in the Dremio server.log on the coordinator?

@balaji.ramaswamy I can’t find my way to the log file. Where can I find the log file ? Is it on Dremio Hub ?

@LucasAvril If this is a TAR ball install, you can do ps -ef | grep dremio and output should have log path, usually under /log

If RPM then will be under var/log/dremio, since it is Ubuntu, I assume it is a TAR

@balaji.ramaswamy I’m using the Docker Version of Dremio. This might be the problem because there is no actual installation and both of the solution you gave me won’t work.

Hi all, I managed to connect from other software from my virtual machine to my SQL Server by changing some settings on my SQL Server and my firewall.

However I have a new error on Dremio:

Do you have any ideas on what can cause this error ?

@balaji.ramaswamy Sorry for spamming, but do you have any idea where this error can come from ?

@LucasAvril Network error could be lot of things, any chance the server.log has a stack with more clues?

@balaji.ramaswamy Seems like the problem solved itself, my Database is linked.
Thank you for helping me since the start of my problems.

@LucasAvril Glad your problem is resolved, thanks a lot for the update