ODBC Connection problem for excel


I’m having some trouble to connect my local excel to my distant Dremio.
My Dremio is hosted on a virtual machine on my Windows Server.
I have installed Excel on my server and I managed to connect my Dremio using this ODBC connection setup:

But when i try with the exact same setup on my local machine, it give me this error:

[Dremio][Connector] (20) Failure occurred while trying to connect to local= (Details: [30001]Connection failure. Host: port:31010. Error: A connection attempt failed because the connected party did not respond properly after a certain time or an established connection failed because the connecting host did not respond.)"

It may be a problem of configuration on my VMware that don’t allow me to connect to my VM.

Thank you in advance for your answers.


@LucasAvril From the machine where ODBC is not connecting to the Dremio server, can we try running the below 2 commands from cmd or terminal window?
telnet 31010

@balaji.ramaswamy Yes, I can’t ping my VM and i think it something about the bridge connection but i can’t configure it on my VMWare.
Both of the commands respond with an error :

@LucasAvril Thats seems to be the issue, can you please check if any firewalls exists that are blocking this request?

@balaji.ramaswamy I managed to ping my server from my local computer using the simple ping command and I also managed to use telnet but on port 1433.
When I tried it on port 31010 this does not work. I also tried to open port 31010 on both computer but this won’t allow me to communicate with my server neither my VM.

@LucasAvril Have you checked with your network admin on why? The other option is to use a port that is already open and not used by other applications, you should be able to get that from your network admin

If you are going to use a port other than 31010 for ODBC/JDBC then dremio.conf needs an entry as this is not the default port


@balaji.ramaswamy In the end I bought an Ubuntu server and it worked perfectly. So i guess it was a problem with the using of the Virtual Machine.

@LucasAvril Could be related to network but as we did not go all the way to the end, no sure what else could have caused it, glad you were able to work around the issue