This is a error when I added elasticSearch source

test environment: dremio2.0
es config: 9200 (node1–node2-node3 :161,162,163)
then appear the error information:
Failure while configuring source [es_192]. Info: Unavailable: Failure getting Elastic health.
Encountered a problem while executing com.dremio.plugins.elastic.ElasticActions$Health@1f0ee58.
Cannot get cluster health information. Please make sure that the user has [cluster:monitor/health] privilege.

but just the same elasticSearch Source I use another dremio2.0(
then it will be sucessful to add.
can you tell me why? or to see some log ?

What operating system are you running Dremio on?

You could get more context from our server.log
Just speculating - I suspect there may be a possible connection issue since it works if you load Dremio onto an ES node and doesn’t work if not.

@bjbhjsj I see that you specified a user/pass. If you are actually using user/pass authentication, you should select “master credentials”, instead of “no authentication”.

Looks like Dremio is sending an Authentication header even when no authentication is selected. This causes AWS to reject the request. Looking for a way to disable this…

thank you all ,I had reboot the dremio then it ok