Can't login to localhost:9047

I’m new to dremio and installed it on Manjaro using a tarball. I’m able to run Jupyter notebook. Can you point me to some documentation that will help me get access to the WebUI?

Did you install Dremio correctly?

Is Dremio successfully running?

If not, can you zip up & share logs?

Hi @bsthinker

Couple of things,

  1. What is the output of netstat -an | grep 9047?
  2. Are you hitting the hostname or IP of the Dremio coordinator on the browser or some kind of load balancer?

Hi Balaji,

I have decided to leave the implementation of Dremio to the IT staff. Thanks for reaching out.


Since, I am also facing similar issue.

  1. port 9047 is in LISTEN mode.
  2. Using browser to load UI but couldn’t connect to http://hostname:9047.

In server.log:
[main] INFO com.dremio.dac.server.WebServer - Started on http://localhost:9047
[main] INFO c.dremio.dac.server.LivenessService - Started liveness service on port 35001

How to change localhost to hostname?

Hi @mniaz,

  1. Using browser to load UI but couldn’t connect to http://hostname:9047.

Are you connecting from the same host on which Dremio is installed? In that case you should connect on http://localhost:9047.

Thanks for your response.
Dremio installed in linux server and am trying to access it through browser but couldn’t connect to UI.
Where to update the linux’s hostname so that it can accessible?

Thanks, Mohammed Niaz

@ben @balaji.ramaswamy Any guidance on configuring localhost to remotehost?


Are you able to ping/ssh to the Linux server from the terminal you are trying to hit the coordinator? Can you try with IP?


@mniaz, when you bring Dremio up, for some of the logging, it will use “localhost” for the hostname. However, if the Dremio ports are open to connections on that host and the host is reachable from where you are (try pinging as @balaji.ramaswamy mentioned), you should be able to connect to Dremio.

Yes, I can ping the remote host using IP.

@mniaz, What happens if you try :9047?

sorry, my bad. We enabled firewall on server that was blocking to access 9047 and now it is accessible after adding port in firewall.
Thank you.