Connection issue

Hi All,

This is my situation: I have an RDP EC2 instance and in that system, I have installed dremio. To connect that dremio to tableau I have installed dremio connector and configured the server details as required (as mentioned in the tutorial).

i have downloaded the tds file from the dremio and when i start i am getting the connection issue. I have the same configuration details as mentioned in dremio connector.


the same thing worked for me when i ran dremio in my local system instead of remotr system

If you followed the same process on your local & EC2 and it only doesn’t work in the cloud, it may be a networking issue? Can you confirm the ports are open & accessible?

I am sorry if anything i made confusion here. Local means when i installed dremio locally in my macheine and set up everything then it worked.

But when i tried to connect the dremio running in EC2 from my local machiene then i am having the issue.

can you explain me more of this, i am using 9047 alone to connect through UI. what should i do to open 31010 port.

Is your tableau running on on your local? and you are trying to connect via tableau to Dremio on EC2, then check this

from your laptop,

telnet 31010

Does the above work? Also what is the port you have given on your Tableau connection details? It should be 31010 and not 9047


Thank you balaji and anthony. Its port issues only and it is wokring now thank you so much

Hi @balaji.ramaswamy
I had the same identical issue, with the same error dialog as above.

My Dremio connector for Tableau would work for a local installation of Dremio (i.e. Direct to Server points to localhost). But the Dremio connector fails to connect against a Dremio instance hosted on a VPC instance in AWS.
When I run telnet (i.e. telnet 31010), the connection fails, telling me that the port is closed from access.
I always assumed that this because AWS closed its ports, including 31010, by design.
Is this not the case? Are users able to access a Dremio instance on AWS through a Tableau data connector?
How is the port issue resolved? On the AWS side? What is the procedure?
Thanks for your help.

Never mind. I figured it out.
For those encountering this problem, this is what I did:
I went to AWS Console, to my EC2 instance, to my Security Group, and added a new rule to open port 31010.