Dremio 19.0 create user ui block

do some tests with dremio 19.0 oss add user with ui will block


+1, can confirm this happens. Steps to reproduce:

  • Run docker run -p 9047:9047 -p 31010:31010 -p 45678:45678 dremio/dremio-oss
  • Click ‘add new user’ and the screen freezes. Didn’t notice any JS errors in the console.

@rickette @rongfengliang Wondering if this is an issue related only to the OSS version? Does the same happen on Community edition too?

Appreciate the reply. Aren’t OSS and community the same thing? Is there a separate Docker image for community? I’ve used https://hub.docker.com/r/dremio/dremio-oss which is described as the community edition. The latter exhibits this UI behaviour.

@rickette I see what you are saying, let me check this and get back to you

I can confirm I’m getting this issue with the latest community build, on Ubuntu 20.04

@balaji.ramaswamy since the REST API for users is NOT available outside of Enterprise (seems a bit backward, when we’re restricted to a username/password scheme), I have NO workaround.

This bug would seem to require an urgent fix.


+1, can confirm this happens with dremio19.0 ,on rhel-server-7.4-x86_64 .@balaji.ramaswamy

+1. Dremio 19.0 on kubernetes with helm.

It also happens on our prod and qa instances, also based on kubernetes.

We tried upgrading to 19.1 in qa and nothing changed.

Please let us know whether there is a workaround and/or if a fix is coming.

@balaji.ramaswamy Are you going to provide an update on this…

For clarity, from my standpoint - Community has the issue

This is a common problem from the posts above

Hi. I confirm the same problem when building without the oss-only tag (comunity edition). Checked in chrome and firefox.

At the same time, you can navigate the user interface through the tab button, fill in the fields and add a user.

This should be fixed in 19.1.0.

I had do some tests 19.1.0 still not working

me too! and I had check dremio 19.1.0 fix report , no anything describe about this issue.

Looks like it is indeed still broken in 19.1, my apologies. I verified it is fixed for the next release.

@doron When is the next release due?

It is still broken in 19.1.

Do we have any updates for it? I still have problems when creating new users on that version (19.1)

I have to say that the lack of feedback/very slow response from Dremio is shall we say… “very disappointing.”

I see lots of traffic on platforms like LinkedIn about how wonderful it all is, and I do like the platform, but Dremio have a lot to learn about communications.

The 20 release will be coming out shortly.

1 Like