Dremio cluster with reverse proxy issue

Hello,

I have a demio cluster with 2 coords and 5 workers.

When I connect directly to the master coordinator everything works fine, but when I connect through a nginx reverse proxy the Dremio logo turns gray, datasets don’t work and I receive the following alert:

image

I have followed the documentation to configure my nginx proxy as follows:

image

I have tried 2 ways:

  • From nginx port 80 to the default dremio port (9047)

  • From nginx port 8080 to port 8080 in dremio changing it to dremio.conf as follows:

    image
    image

I have opened the following sockets in the Azure firewall associated with Dremio and nginx VMs:

  • nginx: 80, 8080 (for the second way)
  • Dremio: 9047, 8080 (for the second way), 31010, 45678 (zookeeper is external).

What am I doing wrong?

@Mandrade

You should just run with one coordinator

Dremio uses Web Sockets. If you encounter the following error message: “Your Internet connection may be offline, or WebSockets to Dremio are being blocked.” , ensure that your environment allows WebSocket communication.

@balaji.ramaswamy

Thanks for the help, after adding some configuration options in the nginx configuration file works correctly:

image

Hi,

I have same issue, but with odbc connector service.
Reverse nginx proxy for UI is working, but how i can configure reverse proxy also for traffic to port 31010?

Thanks!