Changing value for DREMIO_ORIGIN/ WebUI not loading

I am routing my Dremio WebUI through nginx as I cannot access port 9047 directly due to firewall restrictions. I proxy pass /dremio/ to port 9047 in my nginx configs and I confirmed that my app is up and running (I can see: 2020-05-28 16:44:13,381 [main] INFO com.dremio.dac.server.DremioServer - Started on http://localhost:9047) in my server.log.

However, I can’t get the WebUI to work (getting a blank white screen) because the client makes calls to https://{DNS}/runtime.b015e3af0c3817c6f47e.js (which returns 503) instead of https://{DNS}/dremio/runtime.b015e3af0c3817c6f47e.js – same for vendor… etc… Seems like BASE_URL or DREMIO_ORIGIN is set to /. How can I override this variables in the configs such that my calls go to the correct path-- i.e. specify DREMIO_ORIGIN to be /dremio/ instead of /?


One option is to change dremio.conf and change the UI port:

services.coordinator.web.port: 8080

Another option would be to setup nginx to work as a reverse proxy.