Dremio is unable to start

Very excited to see dremio, but I got stuck at step one. When I open dremio and click ‘start’ it says ‘dremio is unable to start’. I didn’t see any log for any more information.

I’m using the community version dremio server on windows 7, behind corporate firewalls. I have checked my jdk which is 1.8.0 following this guide http://docs.dremio.com/quickstart/windows.html.

I’m not sure what else to check. Any guidance would be helpful!

Hi @bihan,

Sorry to hear that you’ve run into this issue! Would you be able to check that the default Java on the machine is 64-bit?

An easy way to do that is to go to the “cmd” application and type in the command java - version. If it is 64-bit then the resulting output should say something similar to:

java version "1.8.0_144"
Java™ SE Runtime Environment (build 1.8.0_144-b01)
Java HotSpot™ 64-Bit Server VM (build 25.144-b01, mixed mode)

If it doesn’t say 64-bit then the default Java version is currently a 32-bit version. Let me know if that ends up being the issue!


It’s 64 bit.

I found an interesting thing. When I look at Java control panel it says 1.8.0_102, but when I do ‘java -version’ on command line, it says 1.7.xx. I then realized that I had jre 1.7.* path in my system path. After removing it, ‘java version’ reports ‘java is not a command’. Then I have to manually add the 1.8.0 path to my system path, after which ‘java version’ shows 1.8.0 x64.

However, this didn’t solve the problem and I’m still seeing the same message.

Just to clarify there is no log file being created correct? The log files should be located under <USER_HOME>\AppData\Dremio\Log. Could you check if the Dremio folder itself gets created at that location as well?


I have the directory created, as

There is no log file

Are there other directories and files created under that Dremio folder? The folders that should be created are logs, db, pdfs, and data. This might help diagnose the issue as to where during startup Dremio is running into an issue.

I am a windows 7 user ( on a personal laptop ) having the identical problem as described in this thread. java -version is 1.8.0_144 (64 bit) and l am unable to start Dremio. The Log directory is empty. Any assistance is appreciated.


Hi @sds,

Would you be able to check what directories are present under that Dremio folder? It should help narrow down where the issue stems from during startup.


The only directory under …AppData\Local\Dremio is the log directory,
and that directory is empty.



Could you confirm that Dremio got installed correctly? The core Dremio files should be located at C:\Program Files\Dremio.


Here is a directory listing…looks like the files are there. WHat was
the resolution to the same problem reported by the other Dremio user?

Directory of c:\Program Files\Dremio

09/15/2017 10:59 AM .
09/15/2017 10:59 AM …
09/15/2017 10:59 AM bin
09/15/2017 10:59 AM conf
08/14/2017 03:06 PM 453,667 Dremio.exe
09/15/2017 10:59 AM jars
08/14/2017 03:06 PM 10,839 license.rtf
09/15/2017 10:59 AM licenses
09/15/2017 10:59 AM share
09/15/2017 10:59 AM 358,116 uninstaller.exe
09/15/2017 10:59 AM winutils

This could be a simple java path issue.
No logs, but java -version does display at cmd prompt, then try launching from that prompt itself.
Open cmd
java -version (if returns, then…)
“C:\Program Files\Dremio\Dremio.exe”
Then try http://localhost:9047

Java is always a sticky wicket on any Windows version depending on how it is installed.
If you can launch the Configure Java console and see listed in system, then it is less likely the path issue.


If all is well with Java, the Event Viewer might add some detail. I always check the security log first.

Minimalist Approach from cmd line.
If this works, it is a simple path issue.

I’ve tested by removing all %PATH% variables and then simply setting path to cmd and javajre and Dremio starts right up.


Here’s the command line with stdout to logs removed. It should launch Dremio with logging displayed within the cmd prompt. (obviously replace /ted/ & \ted\ with appropriate user path) - cmd / c could also be removed in this testing instance and just call java.

cmd /c java -Dhadoop.home.dir="C:\Program Files\Dremio\winutils" -Djava.util.logging.config.class=org.slf4j.bridge.SLF4JBridgeHandler -Ddremio.log.path="C:\Users\ted\AppData\Local\Dremio\log" -Dpaths.local="C:\Users\ted\AppData\Local\Dremio\data" -Dpaths.dist="file:/C:/Users/ted/AppData/Local/Dremio/pdfs" -Dpaths.db="C:\Users\ted\AppData\Local\Dremio\db" -Dpaths.spilling="[file:/C:/Users/ted/AppData/Local/Dremio/spill]" -classpath "C:\Program Files\Dremio\conf;C:\Program Files\Dremio\jars\*;C:\Program Files\Dremio\jars\ext\*;C:\Program Files\Dremio\jars\3rdparty\*" com.dremio.dac.daemon.DremioDaemon dremio start

I followed the script, but unfortunately there is nothing I could find (
Java looks fine ) to shed any light on the situation. I then checked the
Event Viewer logs, and there are no relevant entries; In addition to the
Security section I checked the other event categories as well. Earlier in
this thread I tried reinstalling Dremio from scratch but saw no difference.

FWIW, I also tried installing Dremio on my Windows 7 desktop, and in that
case I get much further; I am able to see the Dremio log entries; And the
error I see there is:
UserException: Could not bind to port 31010.


Hey Steve,

I’m on Win10, but Java issues would be the same, so Java launches on Win7, but you can’t bind to the port, did you check the Windows firewall settings? Also, make sure it isn’t already running and might have gotten orphaned somehow.

c:\>netstat -an | findstr 310
  TCP              LISTENING
  TCP    [::]:31010             [::]:0                 LISTENING

I have admin privileges on my machine but am not running in admin mode. I also have the Windows firewall turned off.

If I try starting from cmd line and am already running I get this.

 com.dremio.common.exceptions.UserException: Could not bind to port 45678.
 Caused by: java.net.BindException: Address already in use: bind

So, unless something else is running on 31010, then firewall is highly suspect.

It’s probably a good idea to change the default ports 2181 and 31010 to something else. 2181 is the default for zookeeper if running and 31010 is used by Apache Drill. This could be the problem, but more likely it’s something related to JAVA.

For port 45678, which is an internal port, we are working on a fix.