Elasticsearch 7.4.2 compatibility

Hi all, I am trying to connect to elastic search 7.4.2 using dremio 4.0.5 community edition. The problem is quite easy to explain because when I try to access tables previews and run queries, I receive the following error message:
“Something went wrong - Invalid response”.
Looking at your documentation (https://docs.dremio.com/data-sources/elasticsearch.html), it seems that only versions 5 and 6 are actually supported, not 7.x.
Do you still confirm it? Moreover, is a fix for this coming?

Thanks in advance


Currently we do not support ES 7.0. It is an enhancement in the product that’s in our roadmap.

Unfortunately no ETA for now.


Lost ES compatibility after upgrading to ES 7 months ago and checking every Dremio update since then… I’m missing Dremio, it’s really impressive what it does and found no better alternative so far… so I hope I can have it back soon!

1 Like

Hello @balaji.ramaswamy -

Dremio not having ES 7.x support is impacting our product roll-out plans. To help myself and fellow community members, I am willing to assign one of my senior software engineers, who worked with other Apache projects like Trafodion to make the necessary enhancements.

However, we will need some help from you to get started. Is this possible?

It goes without saying that whatever we develop will contributed back to Dremio.

Please let me know.


I have not tried it personally, but it is the only thing I have found, check the last commit