Error running helm install to deploy Dremio to AKS

I am trying to deploy dremio_v2 using the command:

helm install dremio_v2 dremio_v2 -f ./dremio_v2/values.yaml

Unfortunately, I am getting the following error:

Error: INSTALLATION FAILED: template: dremio/templates/dremio-master.yaml:22:39: executing "dremio/templates/dremio-master.yaml" at <tpl ($.Files.Glob "config/*").AsConfig $>: error calling tpl: error during tpl function execution for "core-site.xml: \"<?xml version="1.0"?>
<configuration>
  <!-- If you are editing
  any content in this file, please remove lines with double curly braces around them
  -->
...
OUTPUT OMITTED for brevity... 
...
</configuration>
\"": parse error at (dremio/templates/dremio-master.yaml:3): unexpected "\\" in operand

Could this error be triggered from a config error?
I have also tried the helm install without -f ./values.yaml with n success…

Any help appreciated.

Many Thanks,
Emil

@Emil, if you have setup distributed storage for Azure, could you check if values.yaml has any typos around the place where you did that?

Also, see if this post about removing windows style carriage returns helps: Helm install error on EKS - #10 by rafaleon15

@lenoyjacob, thank you for your response I’ll check for any typos as suggested and let you know…

I already tried running helm from ubuntu and the only modified file we have is values.yaml so don’t think this could be the issue, but certainly I’ll check that option too…

I am posting my strange resolution, which I had not time to analyse, but it worked. The errors are parsing errors and although I git cloned the repo locally on windows using the SSH protocol I was getting those parsing errors.
Solution: Under WSL Ubuntu I git cloned the repo using the HTTPS protocol and the parsing errors were gone!

Once again I am not going to try to explain and I hope this will give someone with similar issue a direction to resolve such errors.

Thanks for the update!

My guess is Windows added carriage returns (\r\n) to the charts while when you used WSL/Ubuntu it was just \n which worked.