Query was cancelled because planning time exceeded 60 seconds


#1

Hello guys. I want to create a very big query but I am receiving this error:
"Query was cancelled because planning time exceeded 60 seconds"
Is there a way to change that threshold?
Thanks.


#2

Hi,

You cannot change this threshold. We should look at why planning took this long. If you’re willing to share your job profile, that would be helpful. In the UI, choose “jobs” in the upper-left (next to data sets tab). Then find the job that exceeded 60 seconds and select it; in the details pane, choose “download profile.”

If you’re hesitant to share your profile publicly, please share it with me via email.

thanks
Ron


#3

What source did you connect to? What can you share about the number of tables/collections/indexes or number of partitions (in case of Hive) are you querying?


#4

Sure, I can share it but you can’t upload a .zip file in this forum… only images. So… https://ufile.io/krk84


#5

I’m conected to Postgresql (AWS)
It’s lots of tables with joins.


#6

Hi Bernardo, we’ve created an internal ticket with the profile you’ve attached. We’ll reach out once we have more information on the root cause.


#7

Hi guys, could you please give me a suggestion about the similar problem?
Here is job profile
https://drive.google.com/open?id=0B_TI-qXS6sJVWnQ5LWo3dXlBY2c


#8

Q#5 on TCPH gives me the same ERROR


#9

[Prepare Statement] select supp_nation, cust_nation, l_year, sum(volume) as revenue from ( select n1.n_name as supp_nation, n2.n_name as cust_nation, extract(year from l_shipdate) as l_year, l_extendedprice * (1 - l_discount) as volume from supplier, lineitem, orders, customer, nation n1, nation n2 where s_suppkey = l_suppkey and o_orderkey = l_orderkey and c_custkey = o_custkey and s_nationkey = n1.n_nationkey and c_nationkey = n2.n_nationkey and ( (n1.n_name = ‘RUSSIA’ and n2.n_name = ‘EGYPT’) or (n1.n_name = ‘EGYPT’ and n2.n_name = ‘RUSSIA’) ) and l_shipdate between date ‘1995-01-01’ and date ‘1996-12-31’ ) as shipping group by supp_nation, cust_nation, l_year order by supp_nation, cust_nation, l_year


#10

@shachar what version of Dremio are you on?


#11

Hi, I’m facing the same error when I tried to execute a SUM aggregation for a measure. The execution of SELECT * works with any problem

I attached the profile for the select sum(Amount) and the profil of the VDS original SQL.
Profil_VDS_sources_ok.zip (167,8 KB)
Profil_sum_error.zip (489,7 KB)

Thanks!


#12

HI @Rosmar_Torres

Can you please try this?

If < 3.0
Admin-Advanced Settings-Support Key-Enter “planner.experimental.pclean_logical”, click show and disable-save and try the query again

if 3.0
Admin-Cluster-Support-Support Key-Enter “planner.experimental.pclean_logical”, click show and disable-save and try the query again

Thanks
@balaji.ramaswamy


#13

Hi @balaji.ramaswamy

I checked this setting and It’s disabled in the system. Anything else that you suggest me??

Thanks!


#14

This parameter would be on by default. Did you change it?Can you please send me a screenshot?


#16

We are now working with the new version of Dremio and goes Perfect!
Thanks!