Unable to start: "Dremio is not running" after clicking start on Windows 10

Hi all,

I am new to Dremio and I just installed the lastest Dremio and JAVA 1.8.0_172 on my Windows 10 64-bit computer. However when I click “start” in the GUI, it changes to “Dremio is starting up” for a minute and back to “Dremio is not running”. I have been stuck here for a day… Any help will be appreciated!



What CPU do you have? Dremio requires the AVX2 instruction set, as per here.

Hi mishai, thanks for replying. My CPU is Intel Core i5-7200U

Seems like your CPU indeed supports AVX2. Can you share the log files please?

Thanks @anthony ! The server log is attached. If you need anything else please let me know.

server.zip (19.5 KB)

Hi @Xiao_Marshall_Ma Under program files - dremio - conf there should be a file called logback.xml. Can you please take a backup of the file first then edit the original file, look for the below entry and change error to debug? try to start Dremio again and send us the server.log?

<level value="${dremio.log.root.level:-error}"/>


Hi @balaji.ramaswamy , I just did as you suggested for a couple of times but the issue is still the same. server.log.zip (31.6 KB)

Thank you in advance!

Thanks @Xiao_Marshall_Ma, I will go through the DEBUG logs and get back to you. Meanwhile you can put back error instead of debug or move back the original file as logback.xml

Alright, thanks a lot!

Also had another question,

When you installed this version and before you hit this error, did you hit any other error and you fixed that and next you got this error?


You installed the product fresh and when starting Dremio, this was the 1st error?

There was no other errors (I never saw an error message except that the “starting up” changed back to “not running”.

Hi @balaji.ramaswamy
Any luck?

Hi @Xiao_Marshall_Ma,

@balaji.ramaswamy asked that you turn on some verbose logging. Can you turn on some additional logging in order diagnose this better? Under Program Files\Dremio\conf in the same logback.xml file he pointed you to, can you make a backup and then change the info in:

<logger name="com.dremio">
<level value="${dremio.log.level:-info}"/>

to debug? Then please attach the server.log from Dremio startup.


Hi Ben,

Thanks for reaching out! I am not sure how to change that but I think my logback.xml already has the code you want me to change. Here’s the complete content of my current logback.xml:

<?xml version="1.0" encoding="UTF-8" ?>
%date{ISO8601} [%thread] %-5level %logger{36} - %msg%n ${dremio.log.path}/server.log ${dremio.log.path}/archive/server.%d{yyyy-MM-dd}.log.gz 30
      <pattern>%date{ISO8601} [%thread] %-5level %logger{36} - %msg%n</pattern>

  <appender name="json" class="ch.qos.logback.core.rolling.RollingFileAppender">
    <rollingPolicy class="ch.qos.logback.core.rolling.TimeBasedRollingPolicy">

    <encoder class="net.logstash.logback.encoder.LoggingEventCompositeJsonEncoder">
        <pattern><pattern>{"timestamp": "%date{ISO8601}", "host":"${HOSTNAME}" }</pattern></pattern>
        <arguments />
        <stackTrace />

  <appender name="query" class="ch.qos.logback.core.rolling.RollingFileAppender">
    <rollingPolicy class="ch.qos.logback.core.rolling.TimeBasedRollingPolicy">


server.zip (14.9 KB)

Is it what you expect the file to look like?
And I attached the latest server.log.
Please let me knoe if you need anything else.

Hi @Xiao_Marshall_Ma,

So I don’t see either of the sections of this file that @balaji.ramaswamy or I mentioned. I think your posting was truncated.

Here’s a reference logback.xml with verbose debugging turned on.

logback.xml.zip (1.7 KB)

Hi Ben,

Thanks for the sample file, that helps me a lot as I am newbie to Dremio!

I just ran Dremio again and attached the server.log. Hope it helps.

Thanks a lot!

Marshallserver.zip (49.6 KB)

Thanks @Xiao_Marshall_Ma!

We’re diagnosing this issue and appreciate your help. I’ll add to this thread as I get more information.

Hi @Xiao_Marshall_Ma,

Please take the following steps as a workaround.

  1. go to “Programs and Features” via Start menu, and uninstall Dremio.
  2. go to “C:\Users<username>\AppData\Local” folder in File Explorer, where is user name. Delete “Dremio” folder. “AppData” is a hidden folder, so you have to make it visible.
  3. reinstall Dremio, and wait for 2 minutes before stopping Dremio.

Please let us know how it turns out.


I think it is working now. Turns out it’s quite simple… Thanks a lot!


1 Like

I am facing the same issue now. I tried following the ‘uninstall…and then re-install’ workaround. But it keeps throwing the same error as above.

Dremio is exiting. Failure while starting services.
com.dremio.common.exceptions.UserException: Tried to access non-existent source [__support].
at com.dremio.common.exceptions.UserException$Builder.build(UserException.java:746)
at com.dremio.exec.catalog.CatalogServiceImpl.synchronize(CatalogServiceImpl.java:409)
at com.dremio.exec.catalog.CatalogServiceImpl.getPlugin(CatalogServiceImpl.java:839)
at com.dremio.exec.catalog.CatalogServiceImpl.getSource(CatalogServiceImpl.java:867)
at com.dremio.dac.support.SupportService.start(SupportService.java:348)
at com.dremio.service.SingletonRegistry$AbstractServiceReference.start(SingletonRegistry.java:137)
at com.dremio.service.ServiceRegistry.start(ServiceRegistry.java:74)
at com.dremio.service.SingletonRegistry.start(SingletonRegistry.java:33)
at com.dremio.dac.daemon.DACDaemon.startServices(DACDaemon.java:184)
at com.dremio.dac.daemon.DACDaemon.init(DACDaemon.java:190)
at com.dremio.dac.daemon.DremioDaemon.main(DremioDaemon.java:102)
Java HotSpot™ 64-Bit Server VM warning: ignoring option MaxPermSize=512m; support was removed in 8.0

File C:/tmp/dremio-support does not exist