Dremio installed locally on windows

Hello, installed dremio, connected to local databases and had reflections built and joins done and beautiful! Today I try to start the Dremio server and just says Dremio is unable to start. I checked java path and other items during my research but cannot fix it. I even uninstalled and reinstalled and still same error.

Hi @DanMcDermott,

Forgive me if you’ve already done this, but can you double check that Dremio was not already started when you tried to start? For instance, if you point your browser to localhost:9047 before trying to start, is the Dremio UI being served.

Otherwise, attach any of the Dremio logs here. They may give some insight as to what the problem is:

I had localhost open but doesn’t solve.

Here are log files that I think you need

(Attachment app0.log is missing)

(Attachment access.log is missing)

(Attachment server.log is missing)

wont let me upload my files here but logs only talk about when I first set it up back on 3/2/19. Nothing from today. Not sure how to get log files here without uploading them

You should be able to zip the files in a single directory and attach that.

Can you think of any changes that were made between when you last successfully started and stopped Dremio and now? Did you restart your system?

helplogs.zip (8.0 KB)

I did uninstall some unrelated software I’ve been testing from other fronts but nothing of import. I did restart my PC which I hadn’t since I installed Dremio and had been using for past couple days just fine though but not sure why restarting PC would do anything. I appreciate the help

These logs don’t tell us much… do you see any file called server.out it would be under the same log directory.

I completely uninstalled again and reinstalled and still same issue and now only have this for log file. This seems like a step backward and I do have all install files located in C drive under program files. I do notice that my log file is now current at least app0.log.zip (375 Bytes)

has to be something with uninstall and reinstall as I just installed on my laptop and worked like a charm just like it did first time I installed on my desktop pc. How can I completely clean my desktop and reset it all and reinstall successfully?

How are you uninstalling? There is a Dremio uninstaller.exe under /Program Files/Dremio. You could try running this directly.

Do you know if you have any firewall / security settings that might prohibit the Dremio service from accessing its default ports (even locally)?


Hello, first time I uninstalled I didn’t use the little uninstall tool in the dremio folder but used the control panel uninstall. Not a firewall issue as works just fine on my laptop with a fresh install on same network etc. Has to be something with new installs are not installing all the directories etc. New installs have no errors etc but think very likely something didn’t get removed correctly or registry issues or something but not sure how to diagnose etc. Any help is appreciated. Any kind of dremio old install cleanup tool on the horizon? :slight_smile:

Hello, was working with William and he asked me to do a couple things. I’ve now verified java and seems to be installed correctly but please review attachment and let me know next steps please as the steps didn’t resolve the issue. for screenshot attached, prior to such I did a complete uninstall, then deleted residual dremio folder in Program Files and my user’s appdata folder, restarted PC, reinstalled, verified java, started dremio from cmd line no errors but still says dremio unable to start.