Error running a SQL Server Query

I get this error running a SQL Query: “Can’t call rollback() in auto-commit mode.” I’ve tried selecting the columns and select *. I’ve also tried adding autocommit=false and auto-commit=false to the url. Any ideas?

Hi @eficus,

Do you mean you have a SQL Server source configured and you are trying run queries on it and you get this error?

Are you testing using the web UI or using a client such as the Dremio JDBC driver?

Hi there,
I am using a client and my connection string is jdbc:dremio://localhost:9047?dbname=AdventureWorks2008&autocommit=False
I’ve also tried different values for autocommit and left it off entirely at first. My query is select * from person.person.
Thanks for your help

Auto-commit can’t be disabled for Dremio as it is non-transactional. What client tool are you using? Perhaps it can be configured to not attempt to call rollback().

That is not the real error. Actually I looked further in the logs, and it is not finding the table, VALIDATION ERROR: Table ‘AdventureWorks2008.Person.Person’ not found, so I think I must be calling it wrong. Under Sources is AdventureWorks and I can drill down and get to AdventureWorks2008. I changed my connection string to be jdbc:dremio://localhost:9047?dbname=AdventureWorks and select * from AdventureWorks2008.Person.Person

Thank you, I figured out I need to use this to access it AdventureWorks.“AdventureWorks2008”.“Person”.“Person”

Actually I’m a bit confused about what’s going on:

  • Port 9047 is usually used to get to the web UI
  • The format for specifying server/port doesn’t look correct.
  • You specify the Dremio schema using schema, not dbname.

Here’s the documentation for the JDBC connection string format: