Missing string values: OSX Tableau ODBC Driver

I have installed the ODBC driver for OSX and have a working connection from Tableau to Dremio. When I look at the data source in Tableau, only integers and datetime values are populating, all string columns are empty.

In the Dremio web interface (and through downloaded sample .csv) everything looks normal - all string values are there.

I’ve confirmed the same issue with two different sources.

I’m using:
OSX Mojave 10.14.6
Tableau 10.5 (also tried 2020.4)

Is this a known issue with a workaround?

I am experiencing the same issue in OSX and Windows. I’ve tried on 3 different OSX machines and 3 different Windows machines. The issue is the latest dremio connector. Downgrading to the resolved the issue.
There is definitely a bug in where only integer/numeric data types are being returned. Anything else comes back as blank string.

@ralphjjr ,@coop
We identified this as a problem with our most recent ODBC driver.

As a workaround, you can downgrade to prior versions of the driver. Here is where you can find those: Index of odbc-driver/

Alternatively, you can use the Dremio Tableau SDK connector (JDBC-based): Dremio