Query cancelled because planning time exceeded 60 seconds

I’m running Community Edition 3.1.6 and have a query that will not execute because Planning Time Exceeds 60 Seconds. I have planner.experimental.pclean_logical: toggled off in the Admin Panel.

I have attached the query profile. It is a complex query but I am unable to figure out what the actual issue is.

ExcessivePlanningTime.zip (2.8 MB)

@summersmd, it appears that the planner is generating many different query execution possibilities here based on the number of reflections that cover the query. Can you enter the following key in Admin > Support > Support Keys and disable it?

accelerator.enable_multijoin

Once you’ve done this, please try re-running the query and attaching the profile here. This will change the way the planner handles the reflection substitution and may move you past the logical planning phase.

Ben,

This worked. Thank you. Do you still want me to attach the profile?

@summersmd, yes, please attach the successful query profile at your convenience. It would be insightful to compare this to your earlier one.

31305940-a17b-45af-a51f-27abf068f2f5.zip (1.5 MB)

Hi @ben, i try disable accelerator.enable_multijoin and planner.experimental.pclean_logical but dont worked for me :confused: Can you help me?

I’m running Community Edition 3.1.6-201903070042400578-fdcd3a8

Query Profile:
7b1a3b70-9068-42b4-9b06-d5d1a59ca14a.zip (11,5,KB)