Dremio Docker and Power BI not working

Hi folks,

I am trying to evaluate Dremio in conjunction with Power BI.

For some reason, I am receiving this error message “The field ‘OdbcErrors’ of the record wasn’t found.” while trying to connect to Dremio (running Dremio in Docker with ports exposed on localhost).

The command to spin up the docker instance:

  • docker run -p 9047:9047 -p 31010:31010 -p 45678:45678 dremio/dremio-oss

  • Dremio is up, running and accessible from the web interface

  • A username and credentials for the admin user are set

  • A test dataset has been created

  • I am running on the Power BI September 2020 release, that comes with the certified dremio connector. No additional software / drivers are installed.

In Power BI, I tried to connect using “localhost” as well as “localhost:31010” as the server url. For the username and password I used my working dremio credentials.

I already reset the permissions in Power BI several times and also tried to disable the encrypted connection property. All to no avail.

What am I missing?

Thanks so much

Hello @jeb

This is an incorrect error and has a known issue with us. Please install the ODBC drivers and try.

You can download the drivers from https://docs.dremio.com/drivers/dremio-connector.html