Issues with Power BI Connector

I’m getting the following error when trying to connect via Power BI

Details: “ODBC: ERROR [HY000] [Dremio][DriverSupport] (1160) Cannot enable SSL for the connection when connecting to a server that has not enabled SSL. If the server has SSL enabled, please check if it has been configured to use a SSL protocol version that is lower than what is allowed for the connection. The minimum SSL protocol version allowed for the connection is: TLS 1.2.
ERROR [HY000] [Dremio][DriverSupport] (1160) Cannot enable SSL for the connection when connecting to a server that has not enabled SSL. If the server has SSL enabled, please check if it has been configured to use a SSL protocol version that is lower than what is allowed for the connection. The minimum SSL protocol version allowed for the connection is: TLS 1.2.”

1 Like

Hi Nick,

What version of Power BI, the Dremio Connector, and Dremio server are you using? Do you have SSL enabled on the server?

Are you able to connect to Dremio from the web application (running on port 9047 from your browser)?

I’m on the latest version of all 3. I’ve not made any changes to the config so perhaps I need to enable SSL?

Nick

I had the same exact problem using Power BI desktop as well as at powerbi.com using the Dremio connector (like you, all new versions).

Partial workaround
With Power BI Desktop, once the Dremio Cluster Node had been defined and I hit OK I would get a popup window saying “Unable to connect” and then returning that message.
The workaround was:

  • hit cancel at the Unable to Connect window
  • Open Data source settings which reveals that the data source was, in fact, created.
  • Edit global permissions on the dremio connection and uncheck Encrypt connections
  • Open Data source settings again and re-add the same Dremio Cluster Node you tried previously. The global permission for that node should now be in effect so you can hit OK without an error.

This is kludgey, but it worked.

Powerbi.com, however, does not have the ability to make this kind of workaround. So attempting to add a Dremio connector in Powerbi.com resulted in the same error message, but all you can do it accept that it failed and the new connection is discarded.

Current and complete workaround
What I ended up doing is still setting up a DSN on my workstation (and on the local gateway host) to the coordinator using the Dremio driver, but within PowerBI desktop I made an ODBC connection to the DSN which allowed me to connect to Dremio. At powerbi.com I also set it up as an ODBC connection with the connection string just set to dsn=mycoordinatorname and this successfully connects to Dremio.

Thanks for this. I’ve managed to turn off encryption, but then how do I connect to the list of datasets?

Enabling SSL on the server has also resolved this.

1 Like

Sorry! I know you got this fixed by enabling SSL, but for anyone else (or just to have the knowledge) I’ve updated my original post - I messed up and accidentally left out the last step of the global permissions workaround :frowning_face:

Hi, I’m new to Dremio and I use Azure for the cluster engine and would like to connect it to PowerBI Desktop. I get the same error as above.
Can someone explain in more detail how to solve it/ how to enable SSL ?
That would help me a lot! Thank you
@gray @nick.latocha